User Tools

Site Tools


Sidebar

Announcement

Ahsay Backup Software

Backup Set Types

Supported Storage

Features in OBM / ACB

Features in CBS

Brand and Customize

License

Documentation

Performance Testing

FAQs and Known Issues

Can't Find What You Need?

public:8038_faq:how_to_determine_client_lic_required_before_upgrade

[V8][V9] FAQ: How to determine the number of client licenses required before upgrading from AhsayOBS version 6 to AhsayCBS?

Article ID: 8038
Reviewed: 2019-03-27

Product Version:
Ahsay Software: 8.1 to 8.x
Ahsay Software: 9.1 to 9.x
OS: All platforms

Description

The license model for AhsayCBS (v7+) has changed, client application usages are now calculated per device/installation basis, so if you are upgrading from version 6 to AhsayCBS, you will need to pay attention to the new license requirement.

This article describes the steps to determine the number of additional AhsayOBM / ACB licenses required before you perform the upgrade.

Steps

To determine the number of client licenses required, refer to the following steps:

  • For installation on Windows:

    1. Download the license requirement calculator by Clicking Here.

    2. Extract the downloaded zip file to the AhsayOBS installation folder.

    3. In command prompt, browse to the "check" folder, for example:

      >cd %OBS_HOME%\check
    4. Execute the "ShowV7Usage.bat" batch file, for example:

      >ShowV7Usage.bat
    5. Open the output "usage.xml" file found within the same folder with a text editor (e.g. Notepad++).

    6. The current license usages and new license required will be displayed at the end of the file:

      usage.xml
      ...
              </User>
              <ObmCountV6>103</ObmCountV6>
              <AcbCountV6>14</AcbCountV6>
              <ObmCountV7>126</ObmCountV7>
              <AcbCountV7>14</AcbCountV7>
        </Users>
      From the above example:

      ObmCountV6 = AhsayOBM licenses currently used in version 6 (e.g. 103)
      AcbCountV6 = AhsayACB licenses currently used in version 6 (e.g. 14)

      ObmCountV7 = AhsayOBM licenses to be required in version 8 (e.g. 126)
      AcbCountV7 = AhsayACB licenses to be required in version 8 (e.g. 14)

      You will need an additional of 23 AhsayOBM device licenses (e.g. 126 - 103 = 23) when upgrading from version 6 to 8.

      Note:
      Ignore the parameters' name reference to version 7 (e.g. ObmCountV7 and AcbCountV7), the license requirement for version 7 and 8 are identical.  Also, the numbers used above are for example purposes only.



  • For installation on Linux:

    1. Download the license requirement calculator by Clicking Here.

    2. Extract the downloaded zip file to the AhsayOBS installation folder.

    3. Browse to the "check" folder from the extracted file, for example:

      >cd $OBS_HOME/check
    4. Execute the "ShowV7Usage.sh" script file:

      >./ShowV7Usage.sh
    5. Open the output "usage.xml" file found within the same folder with a text editor.

    6. The current license usages and new license required will be displayed at the end of the file:

      usage.xml
      ...
              </User>
              <ObmCountV6>103</ObmCountV6>
              <AcbCountV6>14</AcbCountV6>
              <ObmCountV7>126</ObmCountV7>
              <AcbCountV7>14</AcbCountV7>
        </Users>
      From the above example:

      ObmCountV6 = AhsayOBM licenses currently used in version 6 (e.g. 103)
      AcbCountV6 = AhsayACB licenses currently used in version 6 (e.g. 14)

      ObmCountV7 = AhsayOBM licenses to be required in version 8 (e.g. 126)
      AcbCountV7 = AhsayACB licenses to be required in version 8 (e.g. 14)

      You will need an additional of 23 AhsayOBM device licenses (e.g. 126 - 103 = 23) when upgrading from version 6 to 8.

      Note:
      Ignore the parameters' name reference to version 7 (e.g. ObmCountV7 and AcbCountV7), the license requirement for version 7 and 8 are identical.  Also, the numbers used above are for example purposes only.



  • For AhsayUBS:

    1. Download the license requirement calculator by Clicking Here, or by running the 'fetch' command.

      >fetch http://s3.amazonaws.com/ahsay-dn/v7/check-v7-license-required.zip
    2. Extract the downloaded zip file to the AhsayOBS installation directory (e.g. /ubs/mnt/esfmfw/obsr/system/obsr)

    3. Browse to the "check" folder from the extracted file, for example:

      >cd $OBS_HOME/check
    4. Execute the "ShowV7Usage.sh" script file:

      >./ShowV7Usage.sh
    5. Open the output "usage.xml" file found within the same folder with a text editor.

    6. The current license usages and new license required will be displayed at the end of the file:

      usage.xml
      ...
              </User>
              <ObmCountV6>103</ObmCountV6>
              <AcbCountV6>14</AcbCountV6>
              <ObmCountV7>126</ObmCountV7>
              <AcbCountV7>14</AcbCountV7>
        </Users>
      From the above example:

      ObmCountV6 = AhsayOBM licenses currently used in version 6 (e.g. 103)
      AcbCountV6 = AhsayACB licenses currently used in version 6 (e.g. 14)

      ObmCountV7 = AhsayOBM licenses to be required in version 8 (e.g. 126)
      AcbCountV7 = AhsayACB licenses to be required in version 8 (e.g. 14)

      You will need an additional of 23 AhsayOBM device licenses (e.g. 126 - 103 = 23) when upgrading from version 6 to 8.

      Note:
      Ignore the parameters' name reference to version 7 (e.g. ObmCountV7 and AcbCountV7), the license requirement for version 7 and 8 are identical.  Also, the numbers used above are for example purposes only.


Keywords

license, cal, cals, calculate, calculation, model, licensing, obm, acb, extra, more

public/8038_faq/how_to_determine_client_lic_required_before_upgrade.txt · Last modified: 2022/04/27 12:09 by kirk.lim