User Tools

Site Tools


Sidebar

Announcement

Ahsay Backup Software

Backup Set Types

Supported Storage

Features in OBM / ACB

Features in CBS

Brand and Customize

License

Documentation

Performance Testing

FAQs and Known Issues

Can't Find What You Need?

public:5341_aua_failed_with_error_cannot_run_program_fuser

ISSUE: Auto update of AhsayOBM failed with error "Cannot run program fuser" (AhsayOBM on CentOS / RHEL)

Article ID: 5341
Reviewed: 23/05/2018

Product Version:
AhsayOBM: 7.3.0.0 or above
OS: CentOS / RHEL

Problem Description

The AhsayOBM client is not updating to the latest version available on the AhsayCBS automatically (even with Auto Update Agent (AUA) enabled for the user).

Further checking on the Auto Update Agent Log, the following error message is displayed:

[YYYY/MM/DD hh:mm:ss][Info] Check if compatible product update is available
[YYYY/MM/DD hh:mm:ss][Info] Compatible product update is found
[YYYY/MM/DD hh:mm:ss][Error] Failed and skipped update, error = Cannot run program "fuser" (in directory "/usr/local/obm/aua"): error=2, No such file or directory

Cause

This issue can occurs if the package PSmisc, which includes the fuser component is not installed on the affected CentOS / Red Hat Enterise Linux machine

Resolution

To resolve the issue, install the package psmisc using the following command:

# yum install psmisc

Keywords

ahsayobm, obm, obc, linux, nix, redhat, red, hat, rhel, centos, fuser, aua, auto, upgrade, agent

public/5341_aua_failed_with_error_cannot_run_program_fuser.txt · Last modified: 2018/05/23 17:36 by edward.chan